Wie kann ich in IntelliJ die Bilder bei Artifacts mit einschließen?

query

Neues Mitglied
Wo kann ich die Dateien im resources mit "exportieren" lassen?

pom.xml:
<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0"
         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
    <modelVersion>4.0.0</modelVersion>

    <groupId>org.example</groupId>
    <artifactId>IPv4_6-Address-Info</artifactId>
    <version>1.0-SNAPSHOT</version>
    <build>
        <plugins>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-jar-plugin</artifactId>
                <configuration>
                    <archive>
                        <manifest>
                            <mainClass>Main</mainClass>
                        </manifest>
                    </archive>
                </configuration>
            </plugin>
        </plugins>
        <resources>
            <resource>
                <directory>resources</directory>
            </resource>
        </resources>
    </build>

    <dependencies>
        <dependency>
            <groupId>io.ipinfo</groupId>
            <artifactId>ipinfo-api</artifactId>
            <version>1.0</version>>
            <scope>compile</scope>
        </dependency>
    </dependencies>

</project>

MANIFEST.MF:
Manifest-Version: 1.0
Created-By: Apache Maven
Build-Jdk: 1.8.0_292
Main-Class: Main
 

Anhänge

  • Bild_2021-05-16_175259.png
    Bild_2021-05-16_175259.png
    22,4 KB · Aufrufe: 27
  • Bild_2021-05-16_175439.png
    Bild_2021-05-16_175439.png
    36,7 KB · Aufrufe: 25

query

Neues Mitglied
Es geht immer noch nicht. Ein Community-Experte von einer anderen Plattform meinte, ich hätte an sich keinen Fehler und hat das Gleiche wie Du hier reingeschrieben - nur, dass er es selber geschrieben hat und nicht einfach den nächstbesten Link rausgesucht hat.
Ich habe diesen Ordner auch zum Testen im Output-Layout drin, aber es funktioniert einfach nicht. Zur Not muss ich einfach alle Bilder über einen Link aufrufen lassen.
 
Oben Unten